ASP Classic - How do I show error messages?

Discussion in 'Parallels Plesk Panel 10.x for Windows Problems, Suggested Fixes, and How-To' started by Karl Mueller, Nov 5, 2011.

  1. Karl Mueller

    Karl Mueller New Member

    Messages:
    11
    I am trying to use ASP Classic, but I cannot get Plesk 10.3 to show the ASP error messages. How do I turn this on?

    I have already set all the error documents to "default" in the Virtual Directory>>Error Documents.

    I also set the Enable ASP Server and Client Side debugging in Virtual Directory>>Virtual Directory Properties.

    What am I missing?

    Thanks.
  2. Revenant

    Revenant New Member

    Messages:
    8
    Last edited: Nov 30, 2011
  3. plexplus

    plexplus New Member

    Messages:
    1
    i suggest to drill down in the following:
    "Website & Domains" -> select your domain from down of the page -> Check "Microsoft ASP support".
    Thats it.
  4. TeamGB

    TeamGB New Member

    Messages:
    1
    Depends on the version of IIS that's underneath

    If you have IIS7 or 7.5 running under Plesk then the default setting is to show a friendly error. This can only be switched off using IIS management console. You should look for "Send Errors to Browser". This will default to false and instead show the standard error message:
    "An error occurred on the server when processing the URL. Please contact the system administrator.

    If you are the system administrator please click here to find out more about this error."

    Setting the "Send Errors to Browser" will show you the full error message.

Share This Page