Cannot connect to SMTP server (Outgoing Mail)

Discussion in 'Parallels Plesk Panel for Linux - 8.x and Older' started by acidbox, Sep 6, 2005.

  1. acidbox

    acidbox New Member

    Messages:
    156
    I am having trouble connecting to the outgoing mail server (SMTP) on my plesk 7.5.4 server. In outlook I get this:
    Then if I try to telnet to the server, I get this:

    I Opened port 587 in my firewall to try to send mail through an alternate port SMTP will not recognize it. When I try to telnet, I get the following:

    Also, there are no errors or connection failures in /usr/local/psa/var/log/maillog

    Does anyone know why this is happening and how to fix it?
  2. jamesyeeoc

    jamesyeeoc New Member

    Messages:
    2,620
    Other than just opening the port, what configurations did you do to tell SMTP to listen/accept on that port?

    Was the Outlook error code one of the following:
    • 0x800ccc15
    • 0x80042108
    • 0x800ccc0e
    • 0x8004210b
    • 0x800CCC0B
    • 0x800CCC79
    • 0x800ccc67
    • 0x80040900
    (all these indicate no response from mail server)

    Try telnet'ing to your server on port 25 and 587 to see if you get any response. Post results here.

    From a SSH root login, see if Qmail and/or IMAP are running in memory:

    ps -ax |grep 'qmail'

    ps -ax |grep 'imap'
  3. acidbox

    acidbox New Member

    Messages:
    156
    Thanks for the reply. If you look at my first post, you will see the results of the telnet attempt. The error is quoted above.

    The outlook code was 0x80042109.

    i did a ps on the qmail:

    and a ps on the imap:

  4. jamesyeeoc

    jamesyeeoc New Member

    Messages:
    2,620
    Sorry, brain malfunction, thought that was still part of the outlook error.

    Ok, looks like the services are all running in memory.

    Have you tried from any other ISP? If you PM me with the IP / domain name I can try from my side.

    Some ISP's do not only blocking or 'filtering' of port 25, but sometimes also use a transparent proxy mechanism for reducing spam transmission. (just a possibility)

    Another obscure reference I found (probably not applicable, but thought I'd mention it) concerns the use of LinkSys routers

    http://www1.linksys.com/support/support.asp?spid=87

    and you didn't reply to:
    Other than just opening the port, what configurations did you do to tell SMTP to listen/accept on that port? (587)
  5. acidbox

    acidbox New Member

    Messages:
    156
    I don't have a LinkSys, however I do have BellSouth and I think they do block port 25. The only thing I did to allow incoming mail from port 587 was open the port, I am not sure how to tell plesk to look for SMTP on that port. That may be a good place to start. Know how to do that?

    I'll also send you a PM. Thanks. (Trying to make the migration from Ensim and it's not going well lol)
  6. acidbox

    acidbox New Member

    Messages:
    156
  7. jamesyeeoc

    jamesyeeoc New Member

    Messages:
    2,620
    Ok, I have verified that I can telnet to both your port 25 and 587, however you are suffering from the SMTP delay issue.

    You need to add the -Rt0 option in your smtp_psa and smtp_additional files.
  8. acidbox

    acidbox New Member

    Messages:
    156
    Looks like that worked great. Thanks again for all your help.
  9. LászlóL

    LászlóL New Member

    Messages:
    1
    smtp error

    Hy guys.

    I'm totaly new in lynux but i get a preconfigured email server. My problem is that i can't send emails, but i can get them. My outlook client gives me the following error message:
    An unknown error has occurred. Account: 'ns2.itteam.ro', Server: 'ns2.itteam.ro', Protocol: SMTP, Server Response: '421 Cannot connect to SMTP server 86.125.35.24 (86.125.35.24:25), connect error 10060', Port: 25, Secure(SSL): No, Server Error: 421, Error Number: 0x800CCC67

    Can anybody help me?

    Thanks a lot
  10. Rodolfo Paparas

    Rodolfo Paparas New Member

    Messages:
    33
    Please click one of the Quick Reply icons in the posts above to activate Quick Reply.

Share This Page