CBM - Online sale fails to provision new domain purchase

Discussion in 'Customer&Business Manager (formerly Plesk Billing)' started by luciddrew, Jan 25, 2012.

  1. luciddrew

    luciddrew New Member

    [server info]
    Panel version 10.3.1
    Application version 10.3.0-1
    Server information Linux 2.6.18-028stab095.1 x86_64 sw-cp-server/1.0.0
    PHP information Version 5.3.8 (128M)
    Database information MySQL: 5.1.54
    cURL information Version OpenSSL/0.9.8b 7.15.5

    How do I fix provisioning for new subscriptions failing through CBM store?
    The plan is for hosting only and was created in CBM and not the Panel.
    Here's the scenario:

    New customer:
    - Successful online store purchase for a basic hosting package (no upgrades/add-ons).
    - Receives the default welcome email and a Credit Card Receipt email.

    CBM Administrator:
    - Open CBM home page for pending accounts and approve the account. (customer can log in to CBM billing now)
    - Check the subscription status for the newly created account and see that the subscription status is Failed.
    - Return to Panel to see the new customer has synced and there is a link to the Business Manager.
    - Customer's domain does not exist in Domains or Subscriptions in the panel.

    Looking through the help files i could only find this @ Serving Your Customer>Changing Subscription Statuses I see...
    Back to CBM>All Settings>Provisioning Policy. (I have not changed any of these)
    Preform hosting provisioning for new customers = Customer paid this item's invoice.

    Am I overlooking something that will complete the automation of CBM?
    Debug is enabled, so if someone can point me in the right direction i'll post a snippet.

    I greatly appreciate any answers wether they're links , similar posts, or if you also have this problem please chime in because I want my online store, and you do too!
    Last edited: Jan 25, 2012
  2. luciddrew

    luciddrew New Member

    Invalid shared IPv4 address

    So I've found more information that I believe pertains to the provisioning problem stated above.

    When looking at the To-Do Items page I get a line item stating
    "Panel Provisioning Failed Queue: 44"

    When looking at the Events page I get a line item from the PleskUnix module
    with the event type "ProcessPanel of subscription" showing a status of "Error"

    At this point I used the Display/Hide Additional Data link and opened the MBAPI Command Output link for this line item.
    I've already looked at All Settings>Hosting Panels and it says my panel is connected.

    I searched the forum for this and cannot find relevant information even in posts for past versions of CBM.

    Has anyone run into a similar problem, know what this means, or know where I can find more information?

  3. EugeneL

    EugeneL Parallels Developers


    Could you please check the following:
    1. Panel module settings in CBM - go to All Settings > Hosting Panels, expand "PleskUnix" group and click "Edit" on local panel. Check the IPv4 address there - is it correct?
    2. Plan settings - go to the plan your subscription was created to, click "Change Settings" and check the setting "IPv4 address" on tab "Properties". What do you have there?
  4. luciddrew

    luciddrew New Member

    Hidden Edit button of mass importance!

    Thank you so much Eugene! I was going to start over with a fresh install!
    I have never seen that settings page in CBM, although I didn't install it in the first place.

    1. I was unaware of the hidden edit button and all the settings within the Panel Group. I was busy clicking the Edit button next to the "load averages" and "List Servers" links which got me nowhere! I have filled in the missing information for IPv4 and also filled in the name servers down below. Score!

    2. The IPv4 address is set to "shared" in my plans.


    I removed my test customer and resubscribed. Activated the account and
    after a small delay it went from Pending to Active. Freakin Awesome!

    Thank you!
    Last edited: Jan 30, 2012

Share This Page