Error: Password file could not be found

Discussion in 'Parallels Plesk Panel 9.x for Linux Problems, Suggested Fixes, and How-To' started by JimmyR1989, May 5, 2012.

  1. JimmyR1989

    JimmyR1989 New Member

    Messages:
    2
    Hi All,

    My Atmail has stopped working, and gives this error when trying to access webmail.

    Error: Password file could not be found

    I have tried removing and re-installing and tried updating. With no luck.

    Can anyone please give me any advice.

    Thank you
  2. onsightdata

    onsightdata New Member

    Messages:
    134
    Edit: /etc/psa-webmail/atmail/atmail_vhost.conf and look for this line:

    Code:
    php_admin_value open_basedir "@WEBMAIL_DOCROOT@:/var/log/atmail:/etc/psa:/tmp:/var/tmp:/etc/psa-webmail/atmail"


    You will see it twice. Be sure to append the ":/etc/psa-webmail/atmail" like you see above. This will set it properly for the template, but it will *not* make it live. To do that, this should work:

    Code:
    /usr/local/psa/admin/bin/websrvmng -a


    Check to see if the template was pushed to your atmail configuration file by running this:

    Code:
    cat /etc/httpd/conf.d/zzz_atmail_vhost.conf | grep open_basedir


    If you see the ":/etc/psa-webmail/atmail" portion appended to the open_basedir line that this last command presents to you, then simply restart apache to apply it:

    Code:
    /sbin/service httpd restart


    If not, edit that file as well and manually insert it in the same way you did to the template file, then restart apache.
  3. onsightdata

    onsightdata New Member

    Messages:
    134
    BTW. Credit has to go to jas8522 from the forum http://www.atomicorp.com/forums/viewtopic.php?f=5&t=5875

    The error you are getting is probably from your update to 1.05 atmail from atomiccorp repo Which fixes the security issue but some people including my self end up with the password error. The fix i posted resolved it right away for me and others.

Share This Page