Fatal error: extension 'sitebuilder' was not found

Discussion in 'Sitebuilder 3.0 for Linux' started by LuciaH, Dec 16, 2009.

  1. LuciaH

    LuciaH New Member

    Messages:
    4
    I use SiteBuilder 2.x.
    I am switching my SiteBuilder 2.x to a new server.

    However when open the browser, I have this error:
    "Fatal error: extension 'sitebuilder' was not found"

    I tried > php -v and this is my result:

    [root@localhost Sitebuilder.2.1.3]# php -v
    PHP: Error parsing /etc/php.d/ioncube-loader.ini on line 1
    Failed loading extension_dir: extension_dir: cannot open shared object file: No such file or directory
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/modules/sitebuilder.so' - /usr/lib/php/modules/sitebuilder.so: undefined symbol: empty_string in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/modules/sitebuilder.so' - /usr/lib/php/modules/sitebuilder.so: undefined symbol: empty_string in Unknown on line 0
    PHP 5.2.6 (cli) (built: Sep 13 2008 11:13:29)
    Copyright (c) 1997-2008 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2008 Zend Technologies
    with the ionCube PHP Loader v3.3.7, Copyright (c) 2002-2009, by ionCube Ltd.



    I open ioncube-loader.ini, it has only 1 line:
    zend_extension=extension_dir => /usr/lib/php/modules => /usr/lib/php/modules/php_ioncube_loader_lin_5.2.so
    and the file php_ioncube_loader_lin_5.2.so is in the folder.


    Can anybody help me with this problem?

    Thanks
  2. IgorG

    IgorG Parallels Team

    Messages:
    16,105
    Check content of /etc/php.d/ioncube-loader.ini file. It should be something like

    and make sure that file is really there:

  3. LuciaH

    LuciaH New Member

    Messages:
    4
    I have successfully fixed the ioncube problem.
    However I am still having problem loading the sitebuilder. As you may see from the command below, the PHP couldn't find the sitebuilder.so. I try to locate the file and copy it from /usr/lib/php4/sitebuilder.so to /usr/lib/php/modules/.
    But I still have this error:
    "/usr/lib/php/modules/sitebuilder.so: undefined symbol: empty_string in Unknown on line 0"

    Thanks.



    [root@localhost ioncube]# php -v
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/modules/sitebuilder.so' - /usr/lib/php/modules/sitebuilder.so: cannot open shared object file: No such file or directory in Unknown on line 0
    PHP 5.2.6 (cli) (built: Sep 13 2008 11:13:29)
    Copyright (c) 1997-2008 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2008 Zend Technologies
    with the ionCube PHP Loader v3.3.7, Copyright (c) 2002-2009, by ionCube Ltd.

    [root@localhost ioncube]# find / -name 'sitebuilder.so'
    /usr/lib/php4/sitebuilder.so

    [root@localhost ioncube]# cp /usr/lib/php4/sitebuilder.so /usr/lib/php/modules/

    [root@localhost ioncube]# ls /usr/lib/php/modules/
    apc.so dom.so json.so mbstring.so mysql.so pdo_mysql.so pdo_pgsql.so pdo_sqlite.so php_ioncube_loader_lin_5.2.so xmlreader.so xsl.so
    dbase.so gd.so ldap.so mysqli.so odbc.so pdo_odbc.so pdo.so pgsql.so sitebuilder.so xmlwriter.so zip.so

    [root@localhost ioncube]# apachectl restart

    [root@localhost ioncube]# php -v
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/modules/sitebuilder.so' - /usr/lib/php/modules/sitebuilder.so: undefined symbol: empty_string in Unknown on line 0
    PHP 5.2.6 (cli) (built: Sep 13 2008 11:13:29)
    Copyright (c) 1997-2008 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2008 Zend Technologies
    with the ionCube PHP Loader v3.3.7, Copyright (c) 2002-2009, by ionCube Ltd.
  4. LuciaH

    LuciaH New Member

    Messages:
    4
    Any solutions ?
    Last edited: Dec 22, 2009
  5. IgorG

    IgorG Parallels Team

    Messages:
    16,105
    You have Sitebuilder v2.x installed, which is incompatible with PHP5, once sitebuilder.so is loaded into PHP5 the corresponding error is noted:

    Please downgrade PHP to v4 to allow for proper Sitebuilder 2 functioning, or upgrade Sitebuilder to v4.5.

Share This Page