How do I change the default vhost directory?

Discussion in 'Parallels Plesk Panel for Linux - 8.x and Older' started by bdensmore, Dec 9, 2008.

  1. bdensmore

    bdensmore New Member

    Messages:
    1
    We just got a dedicated server that has plesk installed. I set up a domain in the Plesk control panel which is located in:

    /var/www/vhosts/mydomain/

    If I upload a document to the httpdocs folder under the directory structure above I can never see that document.

    I found that right now that any request made is actually going through /var/www/vhosts/default/htdocs

    I can't seem to find how to make the requests go through the domain I set up.

    I looked in the psa.conf file but the vhosts line just points to /var/www/vhosts

    Any idea on where I can force everything to look in /var/www/vhosts/mydomain/httpdocs?

    I thought by setting up the domain in Plesk that it would take care of it for me.

    Thanks,
    Ben
  2. bk4linux

    bk4linux New Member

    Messages:
    6
    Values which you have required can be found in the following file:

    /etc/httpd/conf.d/zz010_psa_httpd.conf

    You can change the values at following variables: Here you can replace /default/htdocs with /mydomain/htdocs;


    DocumentRoot /var/www/vhosts/default/htdocs


    AND

    <VirtualHost \
    IP_1:80 \
    IP_2:80 \
    IP_3:80 \
    IP_4:80 \
    >
    ServerName default
    UseCanonicalName Off
    DocumentRoot /var/www/vhosts/default/htdocs
    ScriptAlias /cgi-bin/ "/var/www/vhosts/default/cgi-bin/"
    <IfModule mod_ssl.c>
    SSLEngine off
    </IfModule>
    <Directory "/var/www/vhosts/default/cgi-bin/">
    AllowOverride None
    Options None
    Order allow,deny
    Allow from all
    </Directory>
    <Directory /var/www/vhosts/default/htdocs>
    <IfModule sapi_apache2.c>
    php_admin_flag engine on
    php_admin_flag safe_mode on
    php_admin_value open_basedir "/var/www/vhosts/default/htdocs:/tmp"
    </IfModule>
    <IfModule mod_php5.c>
    php_admin_flag engine on
    php_admin_flag safe_mode on
    php_admin_value open_basedir "/var/www/vhosts/default/htdocs:/tmp"
    </IfModule>
    </Directory>
    </VirtualHost>

Share This Page