iSCSI Multipath in PSBM5

Discussion in 'Installation, Update and Configuration' started by _buriedbones_, Feb 16, 2012.

  1. _buriedbones_

    _buriedbones_ New Member

    Messages:
    5
    Hi,

    I checked on your KB that we have the chance to configure DM-Multipath according to RH5 and also we can use the cloud-linux 6.1 repos in order to install any packages for PSBM5. but when we try to install the device-mapper-multipath it breaks because of the dependencies:


    [root@xxxx yum.repos.d]# yum install device-mapper-multipath
    Setting up Install Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package device-mapper-multipath.x86_64 0:0.4.9-41.el6_1.1 will be installed
    --> Processing Dependency: device-mapper-multipath-libs = 0.4.9-41.el6_1.1 for package: device-mapper-multipath-0.4.9-41.el6_1.1.x86_64
    --> Processing Dependency: kpartx = 0.4.9-41.el6_1.1 for package: device-mapper-multipath-0.4.9-41.el6_1.1.x86_64
    --> Processing Dependency: libmultipath.so()(64bit) for package: device-mapper-multipath-0.4.9-41.el6_1.1.x86_64
    --> Running transaction check
    ---> Package device-mapper-multipath.x86_64 0:0.4.9-41.el6_1.1 will be installed
    --> Processing Dependency: kpartx = 0.4.9-41.el6_1.1 for package: device-mapper-multipath-0.4.9-41.el6_1.1.x86_64
    ---> Package device-mapper-multipath-libs.x86_64 0:0.4.9-41.el6_1.1 will be installed
    --> Finished Dependency Resolution
    Error: Package: device-mapper-multipath-0.4.9-41.el6_1.1.x86_64 (cl-updates)
    Requires: kpartx = 0.4.9-41.el6_1.1
    Installed: kpartx-0.4.9-46.el6.x86_64 (@anaconda-ParallelsServerBareMetal-201202021236.x86_64/5.0.0-1143)
    kpartx = 0.4.9-46.el6
    Available: kpartx-0.4.9-41.el6.x86_64 (cl-os)
    kpartx = 0.4.9-41.el6
    Available: kpartx-0.4.9-41.el6_1.1.x86_64 (cl-updates)
    kpartx = 0.4.9-41.el6_1.1
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest

    How can we override this without breaking PSBM installation?

    Thx
  2. dlenn845

    dlenn845 New Member

    Messages:
    28
    Did you find a soluition?

    I upgraded from psbm 4 to psbm 5 and it broke multipathd.... did you find a solution?
  3. _buriedbones_

    _buriedbones_ New Member

    Messages:
    5
    Hi,

    Unfortunately I didn't and nobody gave a solution for that, I only used bonding and used the features of my SAN provider.

    Thanks, If you find something, please post it.
  4. dlenn845

    dlenn845 New Member

    Messages:
    28
  5. _buriedbones_

    _buriedbones_ New Member

    Messages:
    5
    Great ;)

    When I created this thread we were running different release from the one that is available now, which used different repos.

    Thanks
  6. rani895d

    rani895d Banned

    Messages:
    2
    I upgraded from psbm 4 to psbm 5 and it broke multipathd.... did you find a solution?
  7. _buriedbones_

    _buriedbones_ New Member

    Messages:
    5
    Hey rani895d,

    Have you tried the post of dlenn845? use the centos63.repo and you will be able to install.

    I changed the way in which we connect the SAN because we bought a different one (we were in testing the env in that time) and I bonded the interfaces. On the SAN side we connect to an active SP and standby SP, we don't have ACTIVE/ACTIVE, and so to get HA we bonded the two iscsi connections.

    Depends on the SAN this may help you, but it's completely different of using multipath.

    Let me know if you need anything else.
  8. XuânL

    XuânL New Member

    Messages:
    9
    I upgraded from psbm 4 to psbm 5 and it broke multipathd.... did you find a solution?

Share This Page