Mail forwarding and alias doesn't work after upgrade

Discussion in 'Parallels Plesk Panel 10.x for Linux Problems, Suggested Fixes, and How-To' started by GerardF, Nov 25, 2010.

  1. GerardF

    GerardF New Member

    Messages:
    2
    Hi.

    We have just upgraded Plesk from a 9.5.2 version to 10.0.1 in our cloud server with centos 5.4 64 bit.
    We use postfix mail server as before, but since the upgrade mail forwarding and mail alias stopped working.
    New mails keep on the first account without being forwarded to the second account as selected in Plesk panel.
    New mails never arrive to the main mail account when sent to a mail alias account as selected in Plesk panel.
    We haven't found strange entries in /usr/local/psa/var/log/maillog. Nothing about forwarding and alias.
    Could you give us some idea about this issue?

    Thanks in advance for your help.
  2. IgorG

    IgorG Parallels Team

    Messages:
    16,296
    Did you tried to rebuild mailsettings with mchk utility as it was described on this forum many times?
  3. GerardF

    GerardF New Member

    Messages:
    2
    Hello again Igor.

    Following your suggestions I've used the /usr/local/psa/admin/sbin/mchk command, without additional options.

    Here are the results:

    ==> Checking for: mailsrv_conf_init... ok
    ==> Checking for: mail_mailbox_restore... ok
    ==> Checking for: mailsrv_entities_dump... ok
    ==> Checking for: mail_admin_aliases... ok
    ==> Checking for: mail_auth_dump... ok
    ==> Checking for: mailman_lists_dump... ok
    ==> Checking for: mail_responder_restore... ok
    ==> Checking for: mail_drweb_restore... not exists
    ==> Checking for: mail_kav_restore... not exists
    ==> Checking for: mail_spf_restore... ok
    ==> Checking for: mail_dk_restore... fail
    ==> Checking for: mail_grey_restore... ok
    Errors occured in mail restore procedure
    Some utilities was exited with errors:
    /usr/lib64/plesk-9.0/mail_dk_restore
    I realised that there is a problem with mail_dk_restore (Domain keys i think) but i supose that is not related with alias and forwarding. I'll check it later.
    Once finished this step i've restarted postfix service and nothing changes. The problem is still there.
    Mail alias and forwarding still doesn't work.

    Do you have some clue about the reason of this annoying problem?

    Thanks.
  4. jpvdpoel

    jpvdpoel New Member

    Messages:
    3
    Hi,

    We're currently experiencing the same problem when migrating. Any new information on how to solve this issue?
  5. Consultant1027

    Consultant1027 New Member

    Messages:
    24
    Bump...

    Just migrated a site with lots of forwarded e-mail accounts. They don't forward any more.
  6. lhwparis

    lhwparis New Member

    Messages:
    429
    this problem still exists!!! think this was reported a long time ago any news from parallels???
  7. IgorG

    IgorG Parallels Team

    Messages:
    16,296
    Where is filled report?
  8. MTMark

    MTMark New Member

    Messages:
    5
    Same issue after migrating, forwarded accounts don't work

    I had this same issue after migrating 9.5.4->10.2.0. mchk did fix it, but WHY DO WE HAVE TO DO THIS? This is a lame, lame bug! I have one user alone who didn't get over 100 emails, because this doesn't work. Why isn't mchk run as part of the migration, if it's the fix?
  9. Mr.N

    Mr.N New Member

    Messages:
    1
    I upgraded to Plesk 10.3.1 on Centos 5 with qmail and noticed mail forwarding is no longer working for newly created e-mail accounts.

    I run the /usr/local/psa/admin/sbin/mchk utility. All went smooth. Then restarted qmail. It didn't bring any improvement.

    /usr/local/psa/var/log/maillog is clean - nothing suspicious there - log shows that e-mails are successfully forwarded - but they are not!

    Strangely /var/qmail/mailnames/mydomain/mylogin/.qmail contains a correct forward rule:

    | true
    | /usr/bin/deliverquota ./Maildir
    &my@email.com

    I also tried to delete and recreate accounts and setup mail forwarding anew in the Plesk panel. The forwarding still doesn't work. The e-mails land in the mailbox instead of being forwarded.

    I am running out of ideas... please help me to troubleshoot this issue.
  10. Civilian

    Civilian New Member

    Messages:
    2
    If you have only set up this type of email forwarding within the last 3 days it is being returned to you because the DNS has not propagated yet. Allow about 5 days for this forwarding to start working properly.
    Last edited: Jun 18, 2012
  11. Frank2k

    Frank2k New Member

    Messages:
    1
    I have the same problems, and can't find any solution....
    Is there somebody who has any idea ?......
    No its not the DNS..
  12. jmellon

    jmellon New Member

    Messages:
    4
    Same Issue after migration to a new-version new-server

    emails that moved over to can send but not receive. New domains established after move no problem with send or receive. Scant references in this forum to solution on a known problem.

    I have used /usr/local/psa/admin/sbin/mchk --with-spam, which gets an error, then tried /usr/local/psa/admin/sbin/mchk --without-spam and get no error. Yes I have looked at MX records and trace routes.

    How come this problem which looks like it has been around for a few years has no posted solution. For a For-Fee Licensed product one would expect a bit more?
  13. blue_skies

    blue_skies New Member

    Messages:
    1
    I've just upgraded to a Media Temple (dv) account, with Plesk 10.3.1 - and I'm also having this issue. I've tried re-creating e-mail users, forwards etc. but no luck. Has anyone make progress with this issue?
  14. Janton

    Janton New Member

    Messages:
    28
    Hello,

    Try to edit the .qmail file and modifie this:

    | true
    | /usr/bin/deliverquota ./Maildir
    &my@email.com

    By this:

    | true
    &my@email.com
    | /usr/bin/deliverquota ./Maildir

    So you change the order of the lines 2 and 3. Tell me if works.

    Best Regards.

Share This Page