PHP 4.3.7 - (Component was not installed) + phpMyAdmin problem

Discussion in 'Parallels Plesk Panel for Windows - 8.x and Older' started by SupermanInNY, Jul 8, 2004.

  1. SupermanInNY

    SupermanInNY Guest

    Hi Y'all,

    I've upgraded PHP to 4.3.7 and it works OK.. well.. not great and here is why:

    Before I upgraded I saw 4.3.3 as an installed component.
    Now as I have 4.3.7,. I don't have that anymore.

    PSA --> Server --> Component Info --> Web scripting --> NO ENTRY IS FOUND FOR PHP. Previously there was an entry for PHP 4.3.3,. but since the upgrade,.. there isn't one and all I see is:

    Microsoft ASP 6.0.3790.0
    Microsoft ASP.NET 1.1.4322.0
    SSI 6.0.3790.0
    perl v5.8.0 built for MSWin32-x86-multi-thread
    python 2.3


    BUT, If I check a URL with a .php extension, I am able to use PHP --> I do see the phpinfo() pulling up fine.

    If I look under installed components in the setup of the domains, the checkbox next to PHP is greyed-in and has the checkmark in it,. (i.e. it is selected, but disabled - no changes are allowed) - and it says (Component was not installed)).

    I'm semi-confused:

    I tried to install phpmyadmin to connect to a database.
    However, One domain that finished resolving (DNS wise) is able to run phpMyAdmin with no prob.

    Another domain is able to pull the phpinfo() page, but is unable to get the very same phpMyAdmin (this is still tesing) so I got the config.inc.php file copied as well.. so it should be able to access the very same database.
    But it is prompting me with a Popup box for username and password. Mind you .. this domain has yet to resolve DNS, but I can access it via the IP adderss.
    The only info I modified in phpmyadmin's config file was the username and password.

    I could use some insight with this.

    Thanks,

    -Alon.
  2. SupermanInNY

    SupermanInNY Guest

    Keep the php.ini !!!

    The whole problem started with the PHP upgrade.
    Within php.ini there are specific lines that reference Plesk file structure and locations.
    When Upgrading to a higher PHP version, you need to make a copy of the php.ini. Then install the PHP and then erase the newly created php.ini from the install and replace it with the copy you created before the install.
    Failure to follow these steps will result with PHP errors or Plesk not aware of the install.
    There are no new settings in the php.ini so using the 'old' php.ini with the new PHP version is fine.

    Thank you for the people at ServerMatrix and Plesk who assisted with resolving this issue.

    -Alon
  3. AbsolutelyFreeW

    AbsolutelyFreeW New Member

    Messages:
    418
    I've upgraded to 4.3.9 and I have the same problem, although for plesk for windows 7.0.2... I 've kept the ini file,... still same

Share This Page