Plesk 9.5 mysql admin account password reset

Discussion in 'Parallels Plesk Panel 9.x for Windows Problems, Suggested Fixes, and How-To' started by BobJ, Jul 5, 2011.

  1. BobJ

    BobJ New Member

    Messages:
    3
    I changed my password using plesksrvclient.exe and did not check the "Change admin password in plesk SQL server". No when I try to log into Plesk, I get the following:

    How do I correct this?

    Thanks
  2. IgorG

    IgorG Parallels Team

    Messages:
    16,111
    This happens when Plesk is not able to log into its psa database. The most common causes for this are:
    - SQL server is not running
    - The "admin" user's password was changed.

    For fixing this issue you can try to do following:

    Step 1: Reset the "admin" password for SQL server.

    1. Log into the server via remote desktop
    2. Ensure that SQL server is running.
    3. Open up SQL Server Management Studio and connect to the local server.
    4. In Management Studio, Go to Security > Logins.
    5. Right-Click on the "admin" user and select "Properties"
    6. Under "Password" and "Confirm Password", type in the new password and then click "OK"

    Step 2: Reset the "admin" password in Plesk.

    1. In the command prompt, type (the quotes are required): "%plesk_bin%\PleskSrvClient.exe"
    2. A "Set Plesk Admin Password" dialog will appear. It will display an error message indicating that it can not connect to the Plesk SQL Server. That is OK.
    3. Type in the same password you typed above and then click "OK" followed by "Yes".
    4. You will now be able to log into Plesk with the password you entered.
  3. BobJ

    BobJ New Member

    Messages:
    3
    Thanks for replying. Sorry it took me so long to get back to this...

    A couple of issues. When running the SQL Server Management, I do not see an Admin account, only one: SA. For some reason, I am think it uses mySQL (which is installed and my forums use)

    I am running Windows 2008 if that makes any difference

    Thanks
  4. BobJ

    BobJ New Member

    Messages:
    3
    Also, the error has changed once I ran this: PleskSrvClient.exe

Share This Page