Plesk Windows open_basedir restriction in effect

Discussion in 'Parallels Plesk Panel 10.x for Windows Problems, Suggested Fixes, and How-To' started by bartabc, Mar 13, 2012.

Thread Status:
Not open for further replies.
  1. bartabc

    bartabc Bit Poster

    Messages:
    53
    Hi,

    When i try upload a file using php i receive this error:

    Warning: getimagesize() [function.getimagesize]: open_basedir restriction in effect. File(C:\Windows\Temp\php1D1E.tmp) is not within the allowed path(s): (D:\websites\site.com.br\httpdocs\) in

    I found the solution for linux servers, but how to fix this on Windows Plesk Servers ?
  2. SupportAXL

    SupportAXL New Member

    Messages:
    27
    we were troubled with this problem too ... we resolved it by going into the client's control panel, php settings and adding C:\Windows\Temp to the open_basedir ... so it looks like ...

    E:\inetpub\vhosts\xyz.com\httpdocs\;C:\Windows\Temp\
  3. shaileshs

    shaileshs New Member

    Messages:
    1
    It works ....

    We have got the same error and after using the same ... issue has been resolved ...

    Thanks to SupportAXL :))


    Support
    blog.geek4support.com
  4. Alexey.Plotnitsky

    Alexey.Plotnitsky Parallels Developers

    Messages:
    193
    Hi SupportAXL,

    thanks for sharing! FYI, nowdays Plesk 11 contains TEMP dir by default in PHP open_basedir
  5. aashua

    aashua Banned

    Messages:
    139
    it not working on alphanumeric domains

    it's not working on aplhanumeric domains
    example are
    3akji.in


    any one there
    Thanks / GRABWeb
  6. m0rpheu5

    m0rpheu5 New Member

    Messages:
    113
    I´m getting problem here too with Plesk 11.0.9, everything was working fine with Plesk 10, then i upgrade it to the 11 and i start getting problem like this one:

    OR this:

    I see that on c:\windows\temp, the permission for psacln and psaadm is only to list content folder, not to read or right, is this right?

    I change the open_basedir to Default, but before this was {DOCROOT}\;{TMP}\, i try to as "enter a custom valule" and put there the "{DOCROOT}\;{TMP}\;C:\windows\temp\" but not work too.

    So what could be?

    Thanks
  7. aashua

    aashua Banned

    Messages:
    139
  8. m0rpheu5

    m0rpheu5 New Member

    Messages:
    113
  9. aashua

    aashua Banned

    Messages:
    139
    Check this

    please check php info of your current server and see difference in open base dir paths.

    use php info script.

    I hope this helps.
  10. m0rpheu5

    m0rpheu5 New Member

    Messages:
    113
    I got this on the phpinfo.

    i thing that is right, or am i wrong?

    Thanks
  11. Monavb

    Monavb New Member

    Messages:
    1
    open_basedir restriction in effect warning

    Please give me solution if anybody have it.

    Its urgent.
    Waiting...
  12. NicolasCalvo

    NicolasCalvo New Member

    Messages:
    1
    Hello,

    I had the same problem. I fixed it by setting "none" in "open_basedir" but I think it might be a security issue.

    Does anyone know another way to fix it?

    Thanks.
  13. raulcdm

    raulcdm New Member

    Messages:
    2
    Works, i fixed it setting the open_basedir to C:\Inetpub\vhosts\<hostname>\<clientsite>\;c:\windows\temp\

    I think that is not the best solution. yes, it's might be a security issue.

    OS Microsoft Windows 6.1;build-7601;sp1.0;suite1296;product3
    Panel version 10.4.4 Update #57, last updated at Oct 28, 2013 12:06 AM
  14. philweb

    philweb New Member

    Messages:
    2
    where to change open_basedir

    Hi,

    I tried to change open_basedir in Plesk, but it seems nothing's change !

    Do you know which file is modified when we change default Plesk values ? is it a php.ini dedicated to the <client>website ? I can't find the personnalised changes to see if Plesk to the changes or not

    thaks for your help

    Phil
  15. raulcdm

    raulcdm New Member

    Messages:
    2
  16. philweb

    philweb New Member

    Messages:
    2
    it works

    Great, thank you, I set open_basedir to 'none' in Plesk

    But I noticed that when I personnalised some php parameters in plesk, and then i come back to default values, tthe defaults values are not restored in the Windows registry, so i changed them manually and it works.
Thread Status:
Not open for further replies.

Share This Page