Qmail remote emails stuck in queue

Discussion in 'Parallels Plesk Panel for Linux - 8.x and Older' started by marvay, Dec 12, 2006.

  1. marvay

    marvay New Member

    Messages:
    3
    I know this is more of a Qmail issue, but since it seems Plesk has it's 'own' configured version of Qmail. I thought I'd try these forums. Also, maybe someone has had a similar problem. I did a search but didn't see any existing thread. Sorry if it exists.

    I have Plesk running on a Virtuozzo VPS and just started having problems with Qmail.
    I've configured Qmail to add the virus and spam scanning according to:
    http://www.hostbird.com/beta/index.php?loc=0602-0602
    and
    http://www.hostbird.com/beta/index.php?loc=0603-0603

    I did testing and everything seemed fine. E-mail in and out went smoothly. then I moved 3 domains over to this server and a day later, the e-mails started piling up in the queue.

    I can receive e-mails from another server, as well as another domain on this server. I can send e-mails to another domain on this server, but anything out to another server, gets stuck in the queue.

    Plesk Queue info shows:
    Messages in queue: 0 not preprocessed, 0 local, 630 remote, 630 total.

    In the maillog, I see " deferral: Sorry,_I_wasn't_able_to_establish_an_SMTP_connection._(#4.4.1)/"
    after an outbound e-mail.

    Any help would be appreciated.
    Thanks.

    Mike
  2. marvay

    marvay New Member

    Messages:
    3
    Well, somehow I was able to get it to clear out. Using qmqtool, I backed up the queue, deleted all the files from the queue. Tested to make sure an e-mail would be sent. Then restored the queue. I deleted several suspicious emails, and when I restarted qmail, the queue started delivering successfully. Although I think I caused some damage to the queue. I am finding several errors similar to:
    warning: unable to open todo/22/77791381
    Any Ideas?

    I still have a few questions. Other than /usr/local/psa/var/log/maillog, are there any other log files for qmail? Looking at the LWQ setup, there are several different log files.

    I still have about 10 e-mails in the queue. My test e-mails go through, what would cause these to stick?

    I can't get queue-fix to compile. I've tried qmqtool and queue-repair, but still get the unable to open todo message in the maillog.

    Thanks for any help.
  3. unclethehornet

    unclethehornet New Member

    Messages:
    2
    For what it's worth. I am also having an issue where some remote emails are getting stuck in the mail queue.

    I'm yet to find out why. I'll provide more info if I can.
  4. unclethehornet

    unclethehornet New Member

    Messages:
    2
    Well my problem turned out to be some basic mail configuration (once you know how and why) and nothing to do with plesk.

    Basically, some remote servers didn't like my setup, and thought I might be a spammer.

    Ensure all your bounce addresses are setup correctly (postmaster, anonymous). Ensure your "anonymous" outgoings are setup correctly (@yourcorrecthost). Ensure your reverse DNS is setup correctly (Your IP -> yourcorrecthost).

    Hope that helps.
  5. dhub

    dhub New Member

    Messages:
    19
    Mail Stuck in remote queue

    I have the same problem...getting the similar message.

    Plesk Queue info shows:
    Messages in queue: 0 not preprocessed, 0 local, 1143 remote, 1143 total.

    I tried to stop Dr Web AntiVirus and Anti SPAM services, restart QMail... and could not work.

    I reboot the server and only manage to clear all sending mails in this way!

    But, every soon, the queue will start to build up again.

    How could I fix this problem?

    Help needed urgently.

    D'HUB
  6. bobjones

    bobjones New Member

    Messages:
    16
  7. dhub

    dhub New Member

    Messages:
    19
    thx for the info. ;)

Share This Page