The FTP command execution timed-out.

Discussion in 'Sitebuilder 4.2 for Windows' started by shoggy24, May 14, 2008.

  1. shoggy24

    shoggy24 New Member

    Messages:
    199
    My customers are constantly getting the error
    " FTP error: An unknown error has occurred. The FTP command execution timed-out." when they try to publish. Most times the server load is very light but the error still comes up and they cant publish their work.

    Anyone know what i can do to fix this?
  2. abobykin

    abobykin Parallels Team

    Messages:
    72
    Check for similar exceptions in %SB_DIR%\_logs\application.log file
  3. shoggy24

    shoggy24 New Member

    Messages:
    199
    i looked at the log and this is what i saw relating to the failure error;

    2008-03-27 02:28:34,573 [5] ERROR SWsoft.SiteBuilder.Web.PublishUtil - Unknown error occured
    SWsoft.SiteBuilder.BO.Facade.PublishException: Publish failed: unknown exception ---> Xceed.Ftp.FtpTimeoutException: The FTP command execution timed-out.
    at Xceed.Ftp.Engine.FtpCommand.EndExecute(IAsyncResult asyncResult)
    at Xceed.Ftp.FtpClient.ChangeCurrentFolder(String folder)
    at SWsoft.SiteBuilder.Repository.FtpResources.XceedFtpClient.ChDirToBaseDir()
    at SWsoft.SiteBuilder.Repository.FtpResources.XceedFtpClient.Upload(String path)
    at SWsoft.SiteBuilder.Repository.FtpResources.FtpAdapter.<>c__DisplayClass10.<OpenForWriting>b__f()
    at SWsoft.SiteBuilder.Repository.Resources.ProtocolAdapter.Invoke[T](ObjectMethodInvoker fun)
    at SWsoft.SiteBuilder.Repository.FtpResources.FtpAdapter.OpenForWriting(String fileName)
    at SWsoft.SiteBuilder.Repository.Resources.ResourceFile.Open(FileMode mode, FileAccess access, FileShare share)
    at SWsoft.SiteBuilder.Repository.ResourceHelper.Copy(IResourceItem source, IResourceItem target)
    at SWsoft.SiteBuilder.Repository.FileResources.FileResourceItem.CopyTo(IResourceItem target)
    at SWsoft.SiteBuilder.Repository.Resources.ResourceReplicator.Replicate(IResourceFolder source, IResourceFolder target, ReplicationPolicy policy)
    at SWsoft.SiteBuilder.Repository.Resources.ResourceReplicator.Replicate(IResourceFolder source, IResourceFolder target, ReplicationPolicy policy)
    at SWsoft.SiteBuilder.BO.Facade.Publish.DynamicSitePublisher.OnPublish(PublishSession publishSession, CheckResult cr)
    at SWsoft.SiteBuilder.BO.Facade.Publish.SitePublisher.Publish(PublishSession publishSession)
    at SWsoft.SiteBuilder.BO.Facade.Publish.PublishSiteCommand.<Run>b__0()
    at SWsoft.SiteBuilder.BO.Facade.PublishHelper.CheckPublishExceptions(CheckPublishExceptionsMethod a_method)
    at SWsoft.SiteBuilder.BO.Facade.Publish.PublishSiteCommand.Run()
    --- End of inner exception stack trace --

    but i dont know what to make of it, i know it's not a network problem as i sometimes get the error publishing locally on the server.
  4. abobykin

    abobykin Parallels Team

    Messages:
    72
    What ftp server do you use?
  5. shoggy24

    shoggy24 New Member

    Messages:
    199
    I use microsoft FTP
  6. DawnMccarroll

    DawnMccarroll New Member

    Messages:
    30
    I get the same error

    only it started when I put a hardware firewall. Did you find any answers?
  7. shoggy24

    shoggy24 New Member

    Messages:
    199
    No nothing yet, but i dont think this just an hardware firewall issue since i got the same error working at the console. I could have sworn i read somewhere on how to increase the ftp timeout but i cant locate it anymore
  8. DawnMccarroll

    DawnMccarroll New Member

    Messages:
    30
  9. shoggy24

    shoggy24 New Member

    Messages:
    199
    I have made that change before so i know it is not the problem. and i double checked to make sure it is still there.

    Maybe your error is due to the information supplied, for the first step this is how i enterd it <add key="PreconfiguredUrl" value="http://yourservername.yourdomain.com:80/sites"/>

    I didnt bother completing the second step but i do have an entry in hosts file binding my private IP address to the hostname of my server.
  10. DawnMccarroll

    DawnMccarroll New Member

    Messages:
    30
    Found the issue with Internal Server Error

    When I pasted in the second part to allow NAT, there was period at the end of the line and that was giving me fits.

    I have paid for a dance with Parllels to fix this. I will let you know if they are able to. So far they are living down to their reputation for support. :(

    Dawn
  11. Dmitry Frantsev

    Dmitry Frantsev Parallels Team

    Messages:
    1,922
    Guys, please let me know if any assistance required here. DawnMccarroll, do you have ticket created with Parallels? Let me know how everything goes. By the way, it is recommended to install latest hotfix which could be applyed through Autoupdater section in Sitebuilder admin CP.
  12. shoggy24

    shoggy24 New Member

    Messages:
    199
    DawnMccarroll, was parallel able to help you. I am still constantly getting this error.
  13. DawnMccarroll

    DawnMccarroll New Member

    Messages:
    30
    Autoupdater no longer works for SiteBuilder and I cannot upgrade since the site templates do not work for the newest version. If I did not have clients using the current version, I would drop this lease ASAP. Has any progress been made on this issue?
  14. abobykin

    abobykin Parallels Team

    Messages:
    72
    Can you please post a ticket to get support on this issue?
  15. DawnMccarroll

    DawnMccarroll New Member

    Messages:
    30
    If I do that, I will have to pay for a ticket to fix a bug that is obviously known by Parallels since I was told by Parallels that they know about the bug and are going to fix it. It has been a month or two now (probably longer for the existence of the bug) and I don't know how long it will take for the developers to fix this issue(s), but I have a real ethical stricture against enabling other people to scam me out of money.
  16. Dmitry Frantsev

    Dmitry Frantsev Parallels Team

    Messages:
    1,922

Share This Page