Unable to install Preview 4

Discussion in 'Parallels Plesk Automation' started by ForwardIT, Jul 26, 2012.

Thread Status:
Not open for further replies.
  1. EurowebS

    EurowebS New Member

    Messages:
    14
    Nope it did not help...:)

    [root@ppa Downloads]# cat /etc/hosts
    127.0.0.1 localhost
    192.168.110.197 ppa.viscomp.fb

    [root@ppa Downloads]# ping `hostname` -c4
    PING ppa.viscomp.fb (192.168.110.197) 56(84) bytes of data.
    64 bytes from ppa.viscomp.fb (192.168.110.197): icmp_seq=1 ttl=64 time=0.080 ms
    64 bytes from ppa.viscomp.fb (192.168.110.197): icmp_seq=2 ttl=64 time=0.031 ms
    64 bytes from ppa.viscomp.fb (192.168.110.197): icmp_seq=3 ttl=64 time=0.035 ms
    64 bytes from ppa.viscomp.fb (192.168.110.197): icmp_seq=4 ttl=64 time=0.033 ms

    --- ppa.viscomp.fb ping statistics ---
    4 packets transmitted, 4 received, 0% packet loss, time 3004ms
    rtt min/avg/max/mdev = 0.031/0.044/0.080/0.021 ms
    [root@ppa Downloads]# ./ppa_installer.sh --login admin --password secretpass --admin_email reports@viscomp.bg --ip 192.168.110.197
    [Fri 03 Aug 2012 10:25:51 PM EEST][INFO] Running PPA installation...
    [Fri 03 Aug 2012 10:25:51 PM EEST][INFO] Checking requirements...
    [Fri 03 Aug 2012 10:25:51 PM EEST][INFO] OS: CentOS-5.7-i686
    [Fri 03 Aug 2012 10:25:51 PM EEST][INFO] Checking YUM...
    [Fri 03 Aug 2012 10:25:51 PM EEST][INFO] Checking that SELinux is switched off...
    [Fri 03 Aug 2012 10:25:51 PM EEST][INFO] Checking free disk space...
    [Fri 03 Aug 2012 10:25:51 PM EEST][INFO] Checking wget...
    [Fri 03 Aug 2012 10:25:51 PM EEST][INFO] Checking httpd...
    [Fri 03 Aug 2012 10:25:51 PM EEST][INFO] Skip step 'runInstallation'...
    [Fri 03 Aug 2012 10:25:51 PM EEST][INFO] Skip step 'fixSSO'...
    [Fri 03 Aug 2012 10:25:51 PM EEST][INFO] Skip step 'configureLibSwKey'...
    [Fri 03 Aug 2012 10:25:51 PM EEST][INFO] Skip step 'runConfiguration'...
    [Fri 03 Aug 2012 10:25:51 PM EEST][INFO] Skip step 'setPOAConnection'...
    [Fri 03 Aug 2012 10:25:51 PM EEST][INFO] Skip step 'setPleskConnection'...
    [Fri 03 Aug 2012 10:25:51 PM EEST][INFO] Skip step 'registerRoles'...
    [Fri 03 Aug 2012 10:25:52 PM EEST][INFO] Skip step 'setupDNSHosting'...
    [Fri 03 Aug 2012 10:25:52 PM EEST][INFO] Skip step 'setOwnDNSZonesForSubdomains'...
    [Fri 03 Aug 2012 10:25:52 PM EEST][INFO] Skip step 'assignProvisioningAttributes'...
    [Fri 03 Aug 2012 10:25:52 PM EEST][INFO] Skip step 'createHostingResourceTypeForBranding'...
    ERROR: invalid input syntax for integer: ""
    LINE 1: ...stype_name='DNS management' and resource_types.parent_id='';
    ^
    [Fri 03 Aug 2012 10:25:52 PM EEST][ERROR] Unable to execute sql query in POA: (select rt_id from resource_types where resource_types.owner_id=1 and resource_types.restype_name='DNS management' and resource_types.parent_id='';)
    [root@ppa Downloads]#

    I've change the hostname and rerun installer - the same error

    then i reboot... same

    i create the VM all over again this time with

    i change hostname and reboot the pc just to be shure


    then i set the hostname at the beggining and start the installer:


    [root@ppa ~]# ping `hostname`
    PING ppa.viscomp.fb (192.168.110.197) 56(84) bytes of data.
    64 bytes from ppa.viscomp.fb (192.168.110.197): icmp_seq=1 ttl=64 time=0.482 ms
    64 bytes from ppa.viscomp.fb (192.168.110.197): icmp_seq=2 ttl=64 time=0.055 ms

    ----

    ======================================================================
    CONGRATULATIONS!
    Parallels Plesk Automation was successfully installed.
    To complete system configuration, please proceed to URL: https://192.168.110.197:8443/
    ======================================================================

    [root@ppa Downloads]# cat /etc/hosts
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1 localhost
    #ppa localhost.localdomain
    192.168.110.197 ppa.viscomp.fb ppa

    The last line is set by installer original file was
    192.168.110.197 ppa.viscomp.fb

    As you suggest the hostname check in the installer will be very nice move ;)

    Now everything work fine ! Big thanks to all that was involved with solving

    If i can help with something please let me know .

    Write when you modify the installer to beta test it :)
Thread Status:
Not open for further replies.

Share This Page