Upgrade to 11.5.30 from 11.0.9

Discussion in 'Parallels Plesk Panel 11.x for Windows Problems, Suggested Fixes, and How-To' started by Andrei C, Sep 18, 2013.

  1. Andrei C

    Andrei C Kilo Poster

    Messages:
    171
    Dear Support,

    Why after upgrading to 11.5.30 I see Update #58 for Plesk Panel 11.0.9?

    Please, see link http://s8.postimg.org/hea32je79/upgrade_to_11_5_30.png

    View update logs:

    -----------------------------------------------------------------------------
    Execution failed.
    Command: ai.exe
    Arguments: Array
    (
    [0] => --select-product-id
    [1] => panel
    [2] => --select-release-current
    [3] => --upgrade-installed-components
    )

    Details: BUSY: Update operation was locked by another update process.
    ----------------------------------------------------------------------------
  2. Andrei C

    Andrei C Kilo Poster

    Messages:
    171
  3. IgorG

    IgorG Parallels Team

    Messages:
    16,024
    Please check resolving of autoinstall-win.pp.parallels.com hostname and version of autoinstaller with

    C:\Program Files (x86)\Parallels\Plesk\admin\bin>ai.exe --version
  4. Andrei C

    Andrei C Kilo Poster

    Messages:
    171
    Additional info, when I put Automatic updates I don't see #59 update for 11.0.9, when put Automatic update off I see this.

    P.S. When I try Install update, I see info something like this, no update is needed.

    I check next, this evening and write you:
    C:\Program Files (x86)\Parallels\Plesk\admin\bin>ai.exe --version
  5. IgorG

    IgorG Parallels Team

    Messages:
    16,024
    Check content of file %plesk_dir%/version too.
  6. Andrei C

    Andrei C Kilo Poster

    Messages:
    171
    %plesk_dir%\version

    11.5.30 Windows 2008/2012 20130808.09

    %plesk_bin%\ai.exe --version

    Doing restart of Parallels Installer...
    Parallels Installer 3.15.14 (built on Jul 31 2013 17:34:00)

    I see next on db:
    ------------------------------------------------------------------------------------

    mysql> select * from psa.components;
    +---------------------+--------------------------------------------+
    | name | version |
    +---------------------+--------------------------------------------+
    | psa | 11.0.9 |
    | psa-bu | 11.0.9 |
    +---------------------+--------------------------------------------+

    mysql> select * from upgrade_history;
    +---------------------+--------------+------------+
    | upgrade_date | version_info | db_version |
    +---------------------+--------------+------------+
    | 2013-06-06 22:55:07 | NULL | 11.0.9 |
    | 2013-10-14 23:37:10 | NULL | 11.5.30 |
    +---------------------+--------------+------------+
    Last edited: Oct 15, 2013
  7. IgorG

    IgorG Parallels Team

    Messages:
    16,024
    According to old versions of components looks like you have incorrectly completed upgrade.
    Try to do following:

    1. Reboot server
    2. Run %plesk_bin%\ai.exe manually
    3. Go to add/remove components and try to add some component.
  8. Andrei C

    Andrei C Kilo Poster

    Messages:
    171
    did not help, I try upgrade once, on another testing platform.
  9. InderS

    InderS Product Expert

    Messages:
    946
    are you getting any when you try to run ai.exe after the reboot?

Share This Page